Sage Intacct - Degraded Performance
Incident Report for Sage
Resolved
We have resolved an issue preventing some customers in the US to access the service. The service is available and performing as expected.
Posted Dec 18, 2024 - 04:35 UTC
Investigating
We are investigating a potential issue with the service. An update will be provided within 30 minutes.
Posted Dec 18, 2024 - 04:16 UTC
This incident affected: North America (Sage Intacct).