Managing Subscriptions for UK products - Partial Outage
Incident Report for Sage
Resolved
The issue is resolved and our teams can manage the subscriptions for the UK products.
Posted Sep 16, 2024 - 14:38 UTC
Investigating
We are currently facing difficulties when changing/canceling/creating new product subscriptions for UK products.

The list of products for which managing subscriptions is affected includes but is not limited to:

-Sage 50 Accounts.
-Sage 50 Payroll.
-Sage 200.

The products are performing as expected and their functionalities are not affected.

We are currently investigating.
Posted Sep 16, 2024 - 11:37 UTC